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Advanced Features in Expert Layout Editing Tool:
Parameterized Cells
Introduction
Silvaco Expert is an extremely powerful layout-editing
tool that supports features related to parameterized
cells. Parameterized cells, often called P-cells, increase
designer productivity by adding enormous flexibility
and efficiency to the design process. While standard
cells help the designer to avoid repetitive drawing of
identical pieces of layout, P-cells extend this functionality to the specific parameters that define the mask
geometry. As a result, P-cells assist in the automation
of layout design and help speed-up modification
through the revision of P-cell parameters instead of
wasting valuable resources by repeatedly redrawing
the layout geometry.

Main Features
Expert’s P-cell capability supports the move from
traditional "polygon pushing" to more automated
design styles with the following results:
• Increased design flexibility
• Increased productivity
• Easy maintenance of a small set of flexible
components rather than a continuous reproducing of
all mask geometry.
• Reduce design rule violations and minimize the effort
of entry and editing with specific, parameterized data.

Figure 1. New P-cell Panel

Create New Parameterized Cells
In order to create a P-cell, you must check the
Parameterized cell option in the New Cell panel, in
addition to specifying a cell name and selecting an
associated library. Once the OK button is clicked, the
xi-script panel and the empty layout window for the
P-cell appears (see Figure 1).
The New P-Cell Panel contains the xi-script that defines
a command to generate the P-cell. Unlike the ordinary
xi-script panel, the New P-Cell Panel does not support
editing the "Define Command" statement syntax, which
is automatically generated by EXPERT. Non-editable
text is gray in color. All other necessary commands are
typed inside the outermost Do Begin…End statement.

• Increased multiple, merged instances that are both
DRC and LVS correct.
Continued on page 2....

P-cells are created by writing a xi (Expert Interface)
script command in a special format. xi is an extension
of the LISA (Language for Interfacing Silvaco
Applications) scripting language that includes commands
that execute Expert’s actions. After the P-cell xi-script is
created, compiled, and saved, P-cells appear in the cell
lists of Expert’s various commands. Here, they are
available for viewing, placing their instances, or
changing instance parameters through the standard
cell-instancing dialog.
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Figure 2. Parameterized cell - Spiral and its script

Different Geometry
P-cells are used to create different geometry by generating different xi scripts. Figure 2 shows a spiral pattern
created with P-cells, along with its xi script.

Transistor P-cells change geometry length, width, the
number of gate segments, and other variables by a simple parameter value adjustment. Figure 4 shows the
creation of the P-cell’s four P channel transistors, along
with the change in the parameter value-gate from 1 to 4.

Parameterized cells (P-cells) are device generators and
can generate CMOS single and multiple gate transistors,
resistors, and capacitors. In Figure 3, a single P transistor of P-Cell is generated with its script.

Figure 3

New P-cell control features help prevent less-than-zero
gate numbers during instance creation.

Parameterized cell - Single P channel transistor and its script.
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Current New Features

2. Store the xi scripts and parameters of P-cells
without compiling

1. Control of success

The Apply command allows the user to save an active
xi script and p-cell parameters without compiling the
final cell. This is useful if script and parameter entries
are incomplete and would compile incorrectly.

The LISA RETURN() command is used to monitor the
computation of a P-cell instances, for controlling P-cell
parameters and other areas requiring observation. All
P-cell xi scripts now contain at least one RETURN()
command at the end. RETURN() is usable in other
places as well. Expert checks the value returned by xi
script. If the returned value is NIL, then Expert creates
the P-cell instance. If the returned value is not NIL,
there are two possible results:

Conclusion
Parameterized cells (P-cells) extend traditional geometry
cells to include great design flexibility and automation
through the use of xi-scripts to process specific, userdefined input parameters. The use of P-cells help to
dramatically increase designer productivity. P-cells permit layout changes by simple parameter modification
and without the cumbersome process of redrawing the
geometry. Changes are made easily through the Expert
UI or through modification of the xi script.

• If the p-cell instance is crated/modified by Expert’s
UI, then a dialog box is displayed:
PCell ‘name’(parameter_values) report: Return value:
<ret_value>
Reject Pcell? Y/N
• If the p-cell instance is created/modified through a
xi-script, then the return value for the last instance is
checkable with the pcell_get_return_value()function.

Figure 4. Parameterized cell - Four P channel transistors and its script
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Expert Wiring Tool:
Router at Hand
Introduction
Modern complex circuit designs require automatic
router functionality in circuit layout editors. In
multi-layer hierarchical design, it is often necessary to
build a single wire between two objects or arbitrary
points. It is unpractical to call a heavyweight router
that is hardly aware of the design settings and technology
parameters. Expert’s built-in Wiring Tool helps to
bypass these time consuming operations, since all
necessary information for routing is made available
during Expert session.

To run a wire, select the Tools > Wiring... menu
command. This launches the Wire panel. Expert Wiring
Tool has the following features:
• Select an active layer to run a wire by clicking Tools
> Pick Layer, or by choosing a layer from the Layer Bar.
The Current layer name is then displayed in the Wire
panel and all wires are built in this layer until altered.
• Customize wiring parameters from wire to obstacles
in the Wire panel with the Wire width, End and Join
styles, and Spacing options. Every time an active
layer is changed, the wiring parameters are also
changed in accordance with the technology parameters
or customized settings.

The Purpose and Features of Wiring Tool
The purpose of Expert Wiring tool is to draw a wire in
the active layer between one of the selected source
contacts and one of selected target contacts (Figure 1).
These source and target contacts are chosen by a routing
algorithm in order trace the shortest route between
them. Each of the contacts is a point, an object, or an
electrical node. The resultant wire connects them electrically and avoids obstacles in the active layer in the
whole hierarchy of the current cell.

• Select the Routing area by the corresponding button
on the Wire panel or choose to make it automatically
Adjustable by clicking on the correspondent
checkbox. If a fixed routing area is chosen, a frame
appears around it. In this case, the routing is allowed
only in this area. This saves time and memory if its
certain the area is routable.

Figure 1. Wiring between two points in fixed routing area.
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• Expert divides all contacts by sources and targets.
This indicates the direction of wiring. Choose from
sources or targets in Wire panel.

This compact cell allocation drastically saves memory.
The wave propagation queue is cyclic and has depth=3.
This is enough for flat wave propagation. Estimated
memory usage gain for Win32 model multiplied twenty
times when compared to the first data structure.

• Contacts are points, objects, or electrical nodes. Select
as many contacts in the layout as necessary. The
numbers of source and target contacts are displayed
in the corresponding strings. Click the same contact
twice to deselect it. Click the Assign contact button
to choose the type of wiring source or target contacts:
Point / Object / Node (electrical).

At first sight, access to the compact grid cell data may
seem somewhat slow. This is because the data requires
bit operations. However, compact data requires fewer
CPU cache updates, and importantly prevents addressing
to virtual memory at larger routes (larger routing
grids). Addressing to virtual memory negates most
advantages of the Wiring Tool.

• Click Clean to deselect all contacts.
• After the routing is defined, click Run. The wait time
depends on routing area and design complexity. It
often takes several minutes to build a draft wire for
middle size design cell. The tool displays either the
shortest possible draft wire between the selected
contacts, or one of the warning messages, if wiring
is impossible.

A set of contacts is mix of points, objects, and electrical
nodes in both sources and targets. Wave propagation
from multiple sources to multiple targets locates the
closest pair of these contacts in order to build the shortest possible route between them. Efficient connectivity
between electrical nodes provides a low-cost solution
for electrically connected circuit construction.

• Accept or Reject the draft wire.
• Hide the Wire panel by pressing <Esc>. The contacts
and routing area stay untouched and ready for
wiring. To drop all assignments, just click Finish button.

The routing algorithm recognizes hierarchical obstacles
all over the project cell. Running wire avoids encountered
obstacles whether in a simple, flat design or in a deeply
encapsulated cell hierarchy.

• Along with an easy to use interface, Expert implements
advanced functionality in Wiring algorithm.

Conclusion
Silvaco Expert Wiring tool:

Technology Insight

• Reduces memory usage

Expert’s Wiring Tool is based on a wave propagation
router that employs a uniform routing grid for all
source and target contacts. The Routing grid contains
routing cells small enough to provide path between
obstacles, but large enough to significantly save memory.

• Connects multiple sources to multiple targets with
one wire
• Connects wires to and from electrical Nodes;
• Avoids hierarchical obstacles.

Expert Wiring tool encounters the traditional problem
of trade-off between computational speed and memory
usage. Addressing to machine word is considerably
more speed effective. Taking this into account, the
parameters of routing grid cell is described by the following data structure:
int: empty, source, target, obstacle
int: wave propagation queue number
bool: routed / un-routed
The ineffective memory usage is clear. The same parameters are described by the following compact bit-field
structure:
bit 0-1: empty, source, target, obstacle
bit 2-3: un-routed, cyclic wave propagation queue #1,
cyclic queue #2, cyclic queue #3
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CELEBRITY_C++, C++ Interface for Expert
CELEBRITY_C++, the C++ interface for Silvaco’s Expert
layout tool, is now an exclusive customization language
that expands the tool’s handling of high-level
customization, such as a design application working
with Expert’s database. Users of the interface develop
dynamic link libraries (DLLs) with Microsoft Visual C++
that are stored in the Silvaco install directory. Expert
loads these DLL files and implements the user-defined
commands in the menu bar.
Expert is already customizable with Silvaco’s LISA/xi
scripting language. However, CELEBRITY_C++ extends
these features. The following are some benefits of
CELEBRITY_C++:
• Enables functional access to the Expert layout database
and commands from Visual C++.

Figure 1. Create a new file/project dialog.

• Permits high-level customization through the use of
functions and classes that are prepared in Visual C++

3. Choose "MFC expanded DLL (using MFC common
DLLs)" radio button

• Easy implementation of graphic-user-interfaces (GUIs)
such as dialog boxes, form windows, and toolbars.

4. Click "Finish" to complete the operation and open a
new Visual C++ project.

• Compiles the source code to a fast-running
dynamic link library (DLL) file.

2) Project Setting
Certain library and header files are required to access
Expert database and commands. Take the following
steps to specify these files:

• DLLs are easy to distribute and install.

Using CELEBRITY_C++

1. Click Build > Setting Active from the menu bar and
select "<project name> - Win32 Release".

1) Create a new Visual C++ project
Take the following steps to create a new Visual C++ project:
1. Click File > New from Visual C++ menu bar to
launch the "Create a new file/ project" dialog.

2. Expand the compressed file <SILVACO_INST_DIR>\
examples\expert\plugset.zip to the ExpApi and
Include folders.

2. Click the "MFC AppWizard (dll)" icon and specify
the project name.

3. Click Tools > Options from the menu bar and specify
the path to the header files in the "Directories" page.
4. Click Project > Setting from the menu bar to set the
following:
Output directory:
<SILVACO_INST_DIR>\lib\expert\<version>\x86
-nt\PlugIns
Executable for debug session:
<SILVACO_INST_DIR>\etc\GuiAppStarter.exe
Parameters for Executable: -lib-dir-name
Expert -exe-name Expert
Object / Library module:
<SILVACO_INST_DIR>\lib\expert\<version>\x86-nt\

5. Add the following lines in the Visual C++ project
file StdAfx.h:
#include <afxtempl.h>
#include <afxwin.h>
Figure 2. MFC AppWizard.
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Finally, generate a constructor of CCustomMenu class
by using the CUSTOMENU_ITEM array. The parameters
of CCustomMenu::CCustomeMenu() are the position in
the menu bar, the name of menu, the name of
CUSTOMENU_ITEM array, and the number of items in
the CUSTOMENU_ITEM array.
4) Compiling the program
When the source code is complete, run Build > Build to
compile the program into a DLL. When compiling is
complete, start Expert to check if the program is working
as intended. Place ready-to-deliver DLL files in the
<SILVACO>\ lib\expert\<version>\x86-nt\PlugIns
directory.

Figure 3. Project Setting.

Conclusion: Comparing CELEBRITY_C++
and LISA / xi Scripts

3) Writing source code
It is necessary to write commands that add the menu
items to the DLL file. First, a new C++ source code file
is necessary in order to write the program.

LISA/xi scripts are also used to customize Expert. xi is
an extension of the LISA (Language for Interfacing
Silvaco Applications) scripting language. CELEBRITY_C++
performs most of the same features as a LISA/xi script. The
option is dependent on the project’s objective and scale.

You can add menu items by generating CCustomMenu
constructor, as illustrated in the following example:
void
void
void
void

LISA/xi scripts are easy to develop but are proprietary
to Expert. This makes them ideally suited for simple or
small utility development. Despite its simplicity,
LISA/xi is very flexible.

File1Out();
File1OutAll();
File2Out();
FileIn();

CELEBRITY_C++ is better suited for the development
of larger, more complex applications. CELEBRITY_C++
makes more efficient use of the processor, and is not
modifiable in its compiled form.

CUSTOMENU_ITEM Items1[] =
{
CUSTOMENU_ITEM("Current Cell(&L)",
&File1Out),
CUSTOMENU_ITEM("All Child Cells(&L)",
&File2OutAll)
};
CUSTOMENU_ITEM Items2[] =
{
CUSTOMENU_ITEM("Current Cell(&L)",
&File2Out)
};
CUSTOMENU_ITEM Items[] =
{
CUSTOMENU_ITEM("Output File1(&L)",
Items1, EA_countof(Items1)),
CUSTOMENU_ITEM("Output File2(&D)",
Items2, EA_countof(Items2)),
CUSTOMENU_ITEM(),
CUSTOMENU_ITEM("Load Files(&L)", &FileIn)
};
CCustomMenu cm(10, "Output Files", Items,
EA_countof(Items));

Menu items are defined as arrays of CUSTOMENU_ITEM.
Add extended menus by specifying the name of another
CUSTOMENU_ITEM and the number of items instead of
the name of function. The function EA_countof()counts
the number of items in an CUSTOMENU_ITEM array.
Commands used in CUSTOMENU_ITEM should be
defined in advance.
September 2002

Figure 4. Using users DLL in Expert.
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Calendar of Events
September
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24

RADECS - Italy
RADECS - Italy

IIT2002 - Taos, New Mexico
IIT2002 - Taos, New Mexico
IIT2002 - Taos, New Mexico
ESSDERC - Italy
25 IIT2002 - Taos, New Mexico
ESSDERC - Italy
NUSOD - Switzerland
26 IIT2002 - Taos, New Mexico
ESSDERC - Italy
NUSOD - Switzerland
27 IIT2002 - Taos, New Mexico
NUSOD - Switzerland
28
29 BCTM - Monterey, CA
30 BCTM - Monterey, CA
31 BCTM - Monterey, CA

October
1 BCTM - Monterey, CA
2 Non-Stoichiometric IIIV
Compounds - Monterey, CA
3 Non-Stoichiometric IIIV
Compounds - Monterey, CA
4 Non-Stoichiometric IIIV
Compounds - Monterey, CA
5
6
7 IEEE SOI Conf. - Williamsburg, VA
8 IEEE SOI Conf. - Williamsburg, VA
9 IEEE SOI Conf. - Williamsburg, VA
10 IEEE SOI Conf. - Williamsburg, VA
11
12
13
14
15
16
17
18
19
20
21 GaAs IC Symposium
Monterey, CA
22 GaAs IC Symposium
Monterey, CA
23 GaAs IC Symposium
Monterey, CA
24
25
26
27
28
29
30 LCD/PDP 2002 - Japan
31 LCD/PDP 2002 - Japan

Bulletin Board

BCTM 2000
Monterey, CA is host to the 2002 Bipolar/
BiCMOS Circuits and Technology Meeting
September 29th through October 1st. This year’s
conference emphasizes the strong future of
Bipolar/BiCMOS circuits and technology.
Silvaco has exhibited at BCTM for many years
and looks forward to many more successful
conferences with them.

Visit us at IEEE SOI Conference
Silvaco is the world’s leader in SOI modeling
from the TCAD as well as the SPICE view. See
our Virtual Wafer Fab design flow for SOI for a
comprehensive process and device modeling
solution. Visit us at the IEEE SOI Conference in
historic Williamsburg VA in October 7-10.

Silvaco Returns to GaAs Conference
As a sequel to last year's blockbuster performance,
Silvaco once again exhibits at the GaAs
Conference. Held in Monterey from October 21-23,
Developers, Salesmen, and Application Engineers
will be present to bring you the future of GaAs
design. Highlights included the ultrafast physical
simulator FastBlaze and new HBT models in
SmartSpice and UTMOST.

For more information on any of our workshops, please check our web site at http://www.silvaco.com
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Depo/Etch, MC Implant, S-Pisces, Blaze/Blaze3D, Device3D, TFT2D/3D, Ferro, SiGe, SiC, Laser, VCSELS, Quantum2D/3D, Luminous2D/3D, Giga2D/3D,
MixedMode2D/3D, FastBlaze, FastLargeSignal, FastMixedMode, FastGiga, FastNoise, Mocasim, Spirit, Beacon, Frontier, Clarity, Zenith, Vision, Radiant,
TwinSim, , UTMOST, UTMOST II, UTMOST III, UTMOST IV, PROMOST, SPAYN, UTMOST IV Measure, UTMOST IV Fit, UTMOST IV Spice Modeling,
SmartStats, SDDL, SmartSpice, FastSpice, Twister, Spirit, MixSim, SmartLib, TestChip, Promost-Rel, RelStats, RelLib, Harm, Ranger, Ranger3D Nomad, QUEST,
EXACT, CLEVER, STELLAR, HIPEX-net, HIPEX-r, HIPEX-c, HIPEX-rc, HIPEX-crc, EM, Power, IR, SI, Timing, SN, Clock, Scholar, Expert, Savage, Scout,
Dragon, Maverick, Guardian, Envoy, LISA, ExpertViews and SFLM are trademarks of Silvaco International.
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Hints, Tips and Solutions
Sherry Rauen, Applications and Support Engineer

Q: After I create my round curve and run a DRC check
on my design, it comes up with hundreds of errors
associated with curves. For example, I have the layer
named Isolation in the shape of a rectangle with
rounded corners; the curves have been designed such
that the outer and inner curves are concentric. The DRC
then needs to check that the width of the feature is not
less than 10um all the way around (shown in Figure 1).
After the DRC script is run, it finds errors around the
curves as the curves are approximated with straight
lines (shown Figure 2). How can I solve this problem?

Second, before we run DRC script on round curve, we
need to add the command on DRC script. Any curve
with concentric outer and inner curves will not get
perfectly width 10um with any layout tools. In order to
avoid to get some faulted errors, we have to set the
tolerance command into DRC script to pass DRC. As
shown in Figure 3, I add tolerance:0.01um into DRC
script. After running the new script, we get DRC error
free on curved object as shown in Figure 4.

Figure 3. The new DRC script with added tolerance command.
Figure 1. DRC Script.

Figure 2. Curve Shape with DRC Error.

Figure 4 The new round corner curve with DRC error free.

A: First of all, you need to create the better curve with
larger vertex value, small grid, and polygonized object.
If you go to Setup->Technology->General->Vertex
Value = 100, the round corner will be drawn in much
more smooth shape. Then if you setup grid as small as
possible, select the object, and go to Tools ->
Polygonize, all verities will snap to the grid, and the
round corner is converted into polygon.

September 2002

Call for Questions
If you have hints, tips, solutions or questions to contribute, please
contact our Applications and Support Department
Phone: (408) 567-1000
Fax: (408) 496-6080
e-mail: support@silvaco.com

Hints, Tips and Solutions Archive
Check our our Web Page to see more details of this example
plus an archive of previous Hints, Tips, and Solutions
www.silvaco.com
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