Interactive Measurement in SmartView

Abstract
Interactive measurements offer a convenient method for making quick direct data measurements. The fact that they are driven by the mouse makes them ideal for on-the-fly data annotation.

For interactive measurement operations, the data should be loaded into SmartView and plotted. The data can be received from SmartSpice or loaded from the File→Open menu option in SmartView.

Single Point Probe (Data Marker)
To add a Data Marker, select the Object→Data Marker from the main menu option, or click the Data Marker button on the toolbar, and move the mouse to the location to drop the Data Marker.

A Data Marker will follow the mouse as it is moved across the visible charts. Data Markers are constrained to snap onto any selected trace in the chart, otherwise it will snap to the nearest trace. A single left mouse click drops the trace, and pressing Esc (or the middle mouse button) will cancel the Data Marker placement action.

Once dropped, the Marker will remain in the same chart until it is deleted. To move the Marker, select and drag the small circle on the trace to move the data point; as the marker is moved the text will be updated with the new data point value. Another way to move the Data Marker is to use the < and > keys. The Data Marker text is always automatically visible. Dragging the Marker text changes its offset from the data point. The text will then maintain the constant offset when the data point is dragged.

The Marker Editor window is used to change the color, font, text and visibility of the marker, and can be opened by double clicking on the Data Marker text.

Measure the Difference Between Two Points (Probes)
To add a Probe, select the Menu→Object→Probe menu option, or click the Probe button on the toolbar, and move the mouse to the appropriate location to drop the Probe. The first mouse click drops the first measure point, and the second click drops the last measure point. To move the Probe, drag it to the new location using the mouse.
Probes offer a way to measure the difference in value between two positions on a trace. The two measurements may be on different traces, but the traces must be in the same chart.

By default, the Probe will show only the difference in X and Y values between the two points. The X,Y values for the probe locations can be turned on in the **Probe Editor** after it is placed in the chart.

The Probe can be used with the snap grid, which is comprised of two groups of lines: a vertical and horizontal group. You can control the appearance of each group separately in the **Edit → Preferences → Preferences → Snap Grid** menu option. When one or both of the snap grid groups are enabled, probes can only be placed at the intersection of the snap lines with the traces. This becomes very useful when trying to measure the delay or rise time of traces interactively. The grid can be spaced at regular intervals over a value range. The range is either user defined or extracted from the full range of the chart.

The line spacing intervals can either be a percentage of this range or at specified intervals. Utilizing the percentage spacing, it is very easy to set up SMARTVIEW to measure 20%-80% rise times. Simply set the range to match the logic level (e.g., 3.3V or 5V with a 20%, 10% grid spacing) and then drop the probes on the 20% and 80% snap lines to measure the rise or fall time.

The Metastrings that can be used in the Probe Editor text fields are described in the Table 1:

<table>
<thead>
<tr>
<th>Metastring</th>
<th>Definition</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>%P1NAME%</td>
<td>Name of vector S1 marker is attached to.</td>
<td></td>
</tr>
<tr>
<td>%X1%</td>
<td>X value of the S1 marker location.</td>
<td></td>
</tr>
<tr>
<td>%Y1%</td>
<td>Y value of the S1 marker location.</td>
<td></td>
</tr>
<tr>
<td>%P2NAME%</td>
<td>Name of the vector that the S2 Marker is attached to.</td>
<td></td>
</tr>
<tr>
<td>%X2%</td>
<td>X value of the S2 marker location.</td>
<td></td>
</tr>
<tr>
<td>%Y2%</td>
<td>Y value of the S2 marker location.</td>
<td></td>
</tr>
<tr>
<td>%DELTAX%</td>
<td>%X2% - %X1%</td>
<td></td>
</tr>
<tr>
<td>%DELTAY%</td>
<td>%Y2% - %Y1%</td>
<td></td>
</tr>
<tr>
<td>%GRAD%</td>
<td>%DELTAY%/%DELTAX%</td>
<td></td>
</tr>
<tr>
<td>%YINTER%</td>
<td>Value of Y when X = 0, for the line defined by the S1 and S2 markers.</td>
<td>F(x) = mx + c, m = %GRAD%, c = %YINTER%</td>
</tr>
</tbody>
</table>

Table 1.
Two-point Measurements (Slope Marker)

To add a Slope Marker, select the Object→Slope from the main menu, or click the Slope button on the tool-bar, and move the mouse to the appropriate location to drop the S1 and S2 markers. The first mouse click drops the first measure point, and the second click drops the last measure point. To move a Slope, drag it to the new location using the mouse.

The coordinates of each marker, and the difference in the X and Y values from the S1 to S2 marker are shown in the bottom left corner of the S1 marker’s Chart. The position of the text can be altered by either dragging the text or in the Slope Marker Editor dialog. The slope information of the line joining the S1 and S2 marker can be turned off in the Slope Marker Editor dialog, which can be opened by double clicking on the Slope Data Marker text.

The slope of the line is expressed as the equation of a straight line \( y = \%GRAD\%X + \%YINTER\% \) where \%GRAD\% is the slope of the line, and \%YINTER\% is the value of Y when X=0, also known as the Y intercept value.

The Slope line can either be drawn between the S1 and S2, or drawn as a long line that bisects S1 and S2. This line is controlled from the Slope Marker Editor dialog.

The Slope marker can be dragged around the screen with the mouse, as well as by the small triangles on either end of the vertical lines. When using the triangle handles, the marker will be constrained to move along the trace it is currently on.

The Metastrings that can be used in the Slope Marker Text field are described in Table 2:

<table>
<thead>
<tr>
<th>Metastring</th>
<th>Definition</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>%X1%</td>
<td>X value of the S1 marker location.</td>
<td></td>
</tr>
<tr>
<td>%Y1%</td>
<td>Y value of the S1 marker location.</td>
<td></td>
</tr>
<tr>
<td>%X2%</td>
<td>X value of the S2 marker location.</td>
<td></td>
</tr>
<tr>
<td>%Y2%</td>
<td>Y value of the S2 marker location.</td>
<td></td>
</tr>
<tr>
<td>%DELTAX%</td>
<td>%X2% – %X1%</td>
<td></td>
</tr>
<tr>
<td>%DELTAY%</td>
<td>%Y2% – %Y1%</td>
<td></td>
</tr>
</tbody>
</table>
| %GRAD%        | %DELTAY% – %DELTAX%              | \( F(x) = mx + c \), \(
| %YINTER%      | Value of Y when X = 0, for the line defined by the S1 and S2 markers. | \( m = %GRAD\% \\ c = %YINTER\% \) |

Table 2.
AB Marker

To add an AB Marker, select the **Object→AB Marker** from the main menu, or click the AB Marker button on the toolbar.

The AB Marker is designed to measure the Y values of every visible trace in a chart. Selecting the AB Marker action will add an AB marker to every Cartesian chart that matches the domain of the currently selected chart. The A and B markers will be positioned at either end of the full x-axis range. Dragging either the A or B marker in a chart will move all of the corresponding markers in charts with the same x domain. This allows the Y value to be simultaneously measured for several traces, even when they are in separate charts. The Y values of the traces are drawn next to the point the trace intersects with the A or B marker. The Y value annotation can be turned ON or OFF in the **Single Measurement** dialog. AB markers can be deleted for a chart without affecting the other charts using the standard object deletion methods. The A and B markers also provide the X limits to the **Single Measurement** dialog. Moving the A or B marker will update this dialog automatically.

The Metastrings that can be used in the AB Marker text fields are described in the Table 3:

<table>
<thead>
<tr>
<th>Metastring</th>
<th>Definition</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>%X1%</td>
<td>Location of Marker 1 in x scale</td>
<td></td>
</tr>
<tr>
<td>%X2%</td>
<td>Location of Marker 2 in x scale</td>
<td></td>
</tr>
<tr>
<td>%DELTAX%</td>
<td>%X2%-%X1%</td>
<td></td>
</tr>
</tbody>
</table>

Table 3.

**RMS, Min/Max, Integral, Derivate and Average**

Single Measurement Table can be opened by selecting the Single Measurement button on the toolbar, or from menu option **Tools→Measurements→**:

→Average
→Derivate
→Integral
→Min, Max (P to P)
→Root Mean Square
RMS, Min/Max (Peak to Peak), Integral, Derivate and Average are simple measurements that can be performed from a single utility window (Figure 9). The Y values for all the visible traces in all charts that support AB markers can be measured while these other measurements are being performed. All of the single measurements utilize the AB marker object to constrain the upper and lower boundaries of the measurement.

Each visible trace in a chart is a row in the Single Measurement Table. The Y1 and Y2 columns in the table are the Y values for the trace at the A and B location. By scanning down the Y1 or Y2 column, you can read off the Y values for every visible trace at a specific X value. The two Markers (A and B) can be moved around the screen by dragging the small triangles at both ends of the vertical A and B lines, or changed in the utility window. The Y1 and Y2 values are automatically updated in the table. To view the other measurements (Average, Derivate, Integral, Min/Max (Peak to Peak) and RMS) toggle them on or off in the Utility window. As measurements are turned on or off, the corresponding columns are turned on or off. The measurements use only the portions of the traces between the A and B markers, except for the Derivate, which is the instantaneous derivate value at A and B.

**Average**
The average value of the trace is actually the time average of the trace. The adaptive time stepping algorithm forces the average to be the integral of the trace divided by the time interval of the integration.

\[
\text{avg}(f(x)) = \frac{1}{B_i - A_i} \sum_{n = A_i}^{B_i - 1} \frac{y[n + 1] + y[n]}{2} (x[n + 1] - x[n])
\]

Where:
- \(B_i\) is the data index at point X2.
- \(A_i\) is the data index at point X1.

**Derivative (Instantaneous)**
The instantaneous derivate of a sampled data set is defined as:

\[
\text{deriv} = \frac{y_2 - y_1}{x_2 - x_1}
\]

Where:
- \((x_1, y_1)\) is the first sample point before the requested time.
- \((x_2, y_2)\) is the first sample point after the requested time.
Integral

The integral is defined as the area under the curve with values below zero having a negative contribution to the integral total. The integral technique used is the trapezoidal approximation algorithm. This is the best approach to use with the sample data provided to SmartView from most of the simulators.

\[ \int f(x) \, dx \approx \sum_{n = A_i}^{B_i - 1} \frac{y[n + 1] + y[n]}{2} \times (x[n + 1] - x[n]) \]

Where:

- \( B_i \) is the data index at point \( X_2 \).
- \( A_i \) is the data index at point \( X_1 \).

Min/Max (Peak-to-Peak)

The min and max values are the single smallest and largest values in the input trace between \( A \) and \( B \). The peak to peak value is the difference between the min and the max.

Root Mean Square

The Root mean square of a trace:

\[
\text{rms}(y) = \sqrt{0.5 \times \sum_{n = A_i}^{B_i - 1} \left( y[n]^2 + y[n + 1]^2 \right) \times (x[n + 1] - x[n])} \]

\( B_i \) is the data index at point \( X_2 \).
\( A_i \) is the data index at point \( X_1 \).

Attached Label

To add an Attached Label, simply:

- Click the Attach Label button in the Drawing Objects toolbar, or select the Object→Attach Label menu option.
- Move the mouse to the chart and curve that you wish to attach the label to. As the mouse is moved the text label is updated with any dynamic parameters.
- Click on a chart with the left mouse button to create the attached label.

Min/Max (Peak-to-Peak)

The min and max values are the single smallest and largest values in the input trace between \( A \) and \( B \). The peak to peak value is the difference between the min and the max.

Root Mean Square

The Root mean square of a trace:

\[
\text{rms}(y) = \sqrt{0.5 \times \sum_{n = A_i}^{B_i - 1} \left( y[n]^2 + y[n + 1]^2 \right) \times (x[n + 1] - x[n])} \]

\( B_i \) is the data index at point \( X_2 \).
\( A_i \) is the data index at point \( X_1 \).

An attached label is the same as the Data Marker, except its default string contains the parameter metastring %P1PARAM%. This label can be used for creating a chart annotation attached to a specific curve to provide textual information on the curve, or as an additional annotation of a curve's properties.

Triangle Tool

To add a Triangle Tool, select the Object→Triangle Tool from the main menu, or push the Triangle Tool button on the toolbar, and move the mouse to the location to drop the markers. The first mouse click drops the first measure point, and the second click drops the last measure point. To move Triangle marker, drag it to the new location with the mouse.

The Triangle tool can be used to measure slope of a tangent to a curve. It consists of two vertical lines that intersect a curve at point \( a1 \) and \( a2 \) (these lines will now be referred to as line \( a1 \) and line \( a2 \)), another line that intersects line \( a1 \) at point \( a1 \), and the line \( a2 \) at point \( a3 \) or \( a4 \) depending on the mode of this tool. In the tangent mode, the line intersecting points \( a3 \) and \( a1 \) is a tangent to a curve at point \( a1 \), and in the non-tangent mode, the line intersecting points \( a4 \) and \( a1 \) can have an arbitrary slope. Note that if the axis is not in a linear scale, the tangent line may appear as a non-tangent, and that the Triangle tool works only in Cartesian and Complex charts.
Initially, this tool is in the tangent mode. Close to the point a1 there is a visible letter T. To switch into non-tangent mode, it is necessary to click on the letter T. As a visual feedback, the letter x is drawn over the letter T. In this mode, to change the slope of line a1 a4 to another value, it is necessary to click between the two circles of point a1 and then drag the mouse.

The Triangle tool can be used for measuring the slope of a tangent to the curve at point a1, and the distance between point a2 and a3 (distance between intersection point of tangent line a1 a3 with line a2 and point a2). In the arbitrary slope mode (non-tangent mode), this tool can be used to measure the distance between points a2 and a4 (distance between intersection point of line a1 a4 with line a2 and point a2).

The displayed information, as well as other tool properties (color, fonts, mode, text location and visibility), can be changed by using the Triangle Tool Properties editor. See the following table for what information can be displayed.

As with the slope marker, line a1 can be in one chart and line a2 in another, as long as domain units on both charts are the same.

By default, the Triangle tool displays the following information:

- yLine: the line through points a1 a4
- yTangent: the line through a1 a2
- Coordinates of the points a1 a2 a3 a4
- dX: distance between lines a1 and a2
- dYCourse: distance in y values between a1 and a2
- dYTangent: distance in y values between a1 and a3
- dYLine: distance in values between a1 and a4
The Metastrings that can be used in the Triangle Tool text fields are described in Table 4:

<table>
<thead>
<tr>
<th>Metastring</th>
<th>Definition</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>%X1%</td>
<td>X coordinate of point a1</td>
<td></td>
</tr>
<tr>
<td>%Y1%</td>
<td>Y coordinate of point a1</td>
<td></td>
</tr>
<tr>
<td>%X2%</td>
<td>X coordinate of point a2</td>
<td></td>
</tr>
<tr>
<td>%YC%</td>
<td>Y coordinate of point a2</td>
<td></td>
</tr>
<tr>
<td>%YT%</td>
<td>Y coordinate of point a3</td>
<td></td>
</tr>
<tr>
<td>%YL%</td>
<td>Y coordinate of point a4</td>
<td></td>
</tr>
<tr>
<td>%LINE%</td>
<td>Slope of line through a1 a4</td>
<td></td>
</tr>
<tr>
<td>%TANGENT%</td>
<td>Slope of line through a1 a3</td>
<td>Tangent to the curve at point a1</td>
</tr>
<tr>
<td>%DELTAX%</td>
<td>%X2%-%X1%</td>
<td>Distance on x axis between points a1 and a2</td>
</tr>
<tr>
<td>%DELTAY%</td>
<td>%YC%-%Y1%</td>
<td>Distance on y axis between points a1 and a2</td>
</tr>
<tr>
<td>%DELTAYT%</td>
<td>%YT%-%Y1%</td>
<td>Distance on y axis between points a1 and a2</td>
</tr>
<tr>
<td>%DELTAYL%</td>
<td>%YL%-%Y1%</td>
<td>Distance on y axis between points a1 and a2</td>
</tr>
</tbody>
</table>

Table 4.

**Cross Section Tool**

To place a Cross Section Marker, select the **Object→Cross Section** menu option, and move the mouse to the location to drop it. The Marker will follow the mouse as it is moved across the visible Cartesian charts with swept curve traces inside. A single left mouse click drops it. The Marker will remain in the same chart until it is deleted.

Once dropped, or when the **Calculate** option from the context menu is selected, the **Marker Tool** window appears. This window allows you to set up the swept trace (which will be sliced), the parameter trace as a Z-axis, and the position of the marker on the X-axis. Click the **Calculate** button and the cross section curve is computed. The resulting data is stored in a scratch pad, and is displayed in a chart next to the chart with the source trace.

After the Marker is created, it is possible to move it along the X-axis. The Marker can be dragged around the screen by the small triangle at the bottom end of the vertical line. By default, when the position of the Marker is changed, the generated cross section curve is updated.

Cross Section Marker properties can be changed through the context menu. The **Cross Section Marker Editor** defines different tool modes as well as the color of the vertical line.

Figure 14.

The Cross Section Tool offers a way to explore swept curve variable parameters. The tool works only in a Cartesian chart with swept traces. It takes a vertical slice on the X-axis, and displays the results on a new chart that has swept variable values on the X-axis and the corresponding Y-axis values of the source plotted on the Y-axis.

Figure 15.
If the tool is in **Preview** mode, then a cross section curve will be generated and displayed in real time when the marker is dragged with the mouse along the X-axis of the source chart.

If the **Capture Trace** box is not checked, then each time the marker position is changed, a new cross section trace will be inserted into the chart. If the trace is captured, then the marker position changes due to recalculations and updates of the cross section curve.

If the **In one chart** box is checked, then all cross section curves will be inserted into one chart, otherwise a new chart will be created for each cross section.

In **Manual Insert** mode, it is possible to move the marker without cross section calculation.

To help create a circuit report the analysis plots from SmartView can be saved in many common picture formats.

The **Export Image** feature allows the charts with measurement annotation to be saved into several industry standard file formats, or to the clipboard for direct pasting of the charts into another application. To enable export, select “**File->Export**” and either “**To Clipboard**” or “**To File...**”. The “**To Clipboard**” places a bitmap of the canvas area into the clipboard; it can then be pasted into another application that accepts bitmaps. The “**To File...**” action allows you to select a file name and format, and then save the canvas in the selected format to file. The supported file formats are BMP, JPEG, PBM, PGM, PNG, PPM, XBM, XPM, SVG.

**Summary**

SmartView Interactive Measurements offer a convenient method for making data measurements of:

- single point with navigation to the next/previous point
- two points with the Snap Grid
- two points with X markers
- Y values of every visible trace in a chart
- RMS, Min/Max (Peak to Peak), Integral, Derivate and Average values of every visible trace in a chart
- single point with parametric information
- slope of a tangent to a curve
- swept curve variable parameters

The Marker Editor allows you to change the color, font, text and visibility of the marker, and can be opened by double clicking on the Marker text. Flexible marker content with the ability to display preferred parameters and user comments make SmartView ideal for data annotation.